硬件:
服务器:iis 6
os:windows2003
php:php5
mysql: mysql5.0
在安装的时候遇到过很多问题先是 iis解析php的问题.
1.在php目录下有个php.ini-dist 文件
把他后缀改成 php.ini
然后在ini里 extension_dir = c:\program files\php\ext\ 我的扩展文件在前面的路径
找到下面内容,我用extention ctrl +f ,把前面的; (分号)去掉
;extension=php_mssql.dll
;extension=php_mysql.dll
;extension=php_mysqli.dll
;extension=php_mbstring.dll
加上环境变量
path下:
c:\program files\mysql\mysql server 5.0\bin;c:\program files\php;c:\program files\php\ext;
我加了mysql php相关的路径.
确保
c:\program files\php\ext路径下php_mssql.dll...存在
下面说iis的设置:
我用的xp ghost版本sp3有问题,
下面说windows2003 + iis6
添加isapi筛选器
名称:php
可执行文件:c:\program files\php\php5isapi.dll
前面状态变成绿色就生效了.
在网站的属性里.xp(虚拟目录---配置--映射--添加
扩展名:.php
可执行文件:c:\program files\php\php5isapi.dll
下面动作:限制为:get,head,post
加个执行权权限:纯脚本
基本就ok了
其次在上传好文件设置好wp-config.php文件后出现了令人恼火的wp warning: cannot modify header information错误,这其实是因为大家在使用windows编辑器编辑wp-config.php文件的时候保存使用了utf-8编码保存,其实wp-config.php应该使用ansi编码保存。将wp-config.php修改后用ansi编码保存后就可以解决错误了。
